summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-08-31 19:08:32 (GMT)
committerSimon McVittie <smcv@debian.org>2011-08-31 19:08:32 (GMT)
commitc42fa5090b554bdcef3a3869e72743d84bce95d8 (patch)
treece3d0a3e37c16f44283be40ece709e34675b7e8b
parentbbfc49140e05bc62b6b9aec1f430853ef8d30477 (diff)
downloadlibproxy-maemo.tar.gz
libproxy-maemo.tar.xz
Use correct version number for a Debian derivativemaemo
* Use correct version number for a Debian derivative * Install helper binaries to /usr/lib/libproxy/0.4.7 like the modules - /usr/libexec isn't used on Debian and derivatives, and we should have either our version or SONAME in the path to be co-installable with a hypothetical libproxy2
-rw-r--r--debian/changelog10
-rw-r--r--debian/control1
-rw-r--r--debian/libproxy1.install2
-rwxr-xr-xdebian/rules4
4 files changed, 13 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 1925e9a..190f6e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,15 @@
-libproxy (0.4.7-1+maemo0) unstable; urgency=low
+libproxy (0.4.7-0maemo1) UNRELEASED; urgency=low
+ [ Cosimo Alfarano ]
* New upstream release
+ [ Simon McVittie ]
+ * Use correct version number for a Debian derivative
+ * Install helper binaries to /usr/lib/libproxy/0.4.7 like the modules -
+ /usr/libexec isn't used on Debian and derivatives, and we should have
+ either our version or SONAME in the path to be co-installable with a
+ hypothetical libproxy2
+
-- Cosimo Alfarano <cosimo.alfarano@collabora.co.uk> Thu, 28 Jul 2011 17:23:17 +0100
libproxy (0.3.1-2) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 12350a8..0bb7799 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,6 @@ Build-Depends: cdbs,
gnome-pkg-tools,
cmake,
libdbus-1-dev,
-# /!\ we have a build-depends loop with webkit
gconf2,
libxmu-dev
Standards-Version: 3.8.3
diff --git a/debian/libproxy1.install b/debian/libproxy1.install
index 18c3894..9442bd7 100644
--- a/debian/libproxy1.install
+++ b/debian/libproxy1.install
@@ -1,3 +1,3 @@
debian/tmp/usr/lib/libproxy.so.*
debian/tmp/usr/lib/libproxy/*/modules
-debian/tmp/usr/libexec/*
+debian/tmp/usr/lib/libproxy/*/px*
diff --git a/debian/rules b/debian/rules
index 75d24b4..0241b1b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,9 @@ DEB_CMAKE_EXTRA_FLAGS += -DWITH_DOTNET="OFF" \
-DWITH_PYTHON="OFF" \
-DWITH_VALA="OFF" \
-DWITH_GNOME3="OFF" \
- -DWITH_GNOME="ON"
+ -DWITH_GNOME="ON" \
+ -DLIBEXEC_INSTALL_DIR="/usr/lib/libproxy/$(DEB_UPSTREAM_VERSION)" \
+ $(NULL)
#binary-install/python-libproxy::
# dh_pysupport -p$(cdbs_curpkg)